Pages: [1]
Author Topic: Read CSV doesn't work  (Read 517 times)
Posts: 1

« on: August 20, 2014, 09:20:56 AM »


I didn't work for a long time with Rapit Miner and I have a problem with reading csv files.
I use the "Read CSV" operator, select my csv file with the "Import Configuration Wizard", follow the steps and want to do some kind of clustering afterwards. When I run the prozess there is always the Error Message: "No input file was defined. No file input defined: depending on the source type configuration of your operator, you have to either connect the file input port or define the parameters which specifies the file to be read."

Reading Excel files work fine.

I'm using RapidMiner 5.3.013.

For more information please contact me.

Thankls for your help.

Full Member
Posts: 101

« Reply #1 on: August 20, 2014, 10:57:49 AM »

Hi dajoedic,

it looks like there is no file associated to the "Read CSV" operator. Did you use the import wizard directly from the parameter tab of the operator? It would be great if you could post the xml code of your process here.

« Last Edit: August 20, 2014, 11:38:44 AM by homburg » Logged

Please add [SOLVED] to the topic title when your problem has been solved! (do so by editing the first post in the thread and modifying the title)
Please click here before posting.
Posts: 10

« Reply #2 on: September 04, 2014, 10:03:30 PM »

with a new process locate the read CSV operator
add it to the main process window
wire the op port to res
click on the wizard
locate the csv file
click next
in the file reading confirm encoding = UTF-8
in the comma separation note the default = ';'
you need to set this to ','
data should be there now.

if its not the case then as per the previous response you will need to send the XML code for analysis
Pages: [1]
Jump to: