Pages: [1]
  Print  
Author Topic: JDBC Driver for Interbase XE3  (Read 465 times)
WarriorOnTheEdge
Newbie
*
Posts: 2


« on: December 04, 2013, 06:24:52 AM »

I can't seem to get the jdbc driver for InterBase XE 64 bit (Developer Edition) to work in RMS 6.0.001.

After adding the driver I see this in the jdbc_properties.xml file:

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<drivers>
  <driver dbnameseparator=":" defaultport="3050" driver_jar="C:\Program Files\RapidMiner\RapidMiner Studio\lib\interclient.jar" drivers="interbase.interclient.Driver" name="Interbase" urlprefix="jdbc:interbase://"/>
</drivers>

Note that I placed a copy of interclient.jar in "C:\Program Files\RapidMiner\RapidMiner Studio\lib\jdbc" and pointed RM to that directory.

The show database drivers dialog shows the interbase drive as unavailable.

TIA

Mark
Logged
Marco Boeck
Administrator
Hero Member
*****
Posts: 905


WWW
« Reply #1 on: December 04, 2013, 09:11:30 AM »

Hi,

I just tried adding a DB driver for some DB not shipped with RM Studio and it worked fine for me. It did the following:

1. Copy jdbc driver .jar into C:\Program Files\RapidMiner\RapidMiner Studio\lib\jdbc\ folder
2. Start RM Studio, go to "Tools" -> "Manage Database Drivers"
3. Click "Add", enter settings and point it to the driver .jar file and select the correct Driver class
4. Click "Save"
5. Restart RM Studio
6. Go to "Tools" -> "Show Database Drivers" and there it is shown as available

If the above does not work for you for some reason, you can also manually edit the jdbc_properties.xml (while RM Studio is closed) so it looks for example like this:
Code:
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<drivers>
 <driver dbnameseparator="/" defaultport="1234" driver_jar="C:\Program Files\RapidMiner\RapidMiner Studio\lib\jdbc\derbyclient.jar" drivers="org.apache.derby.jdbc.ClientDriver" name="Derby" urlprefix="jdbc:derby://"/>
</drivers>
When you start RM Studio afterwards, it should show up in both dialogs and be ready for use.

Regards,
Marco
Logged

WarriorOnTheEdge
Newbie
*
Posts: 2


« Reply #2 on: December 04, 2013, 02:19:00 PM »

Hello Marco,

I found in SQuirrel they recommend (full) url  like so:

jdbc:interbase://<server>/<full_db_path>

So I tried putting the url prefix in as:

jdbc:interbase://

The driver is now available and I can connect.

For your reference jdbc_properties.xml is as follows:

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<drivers>
  <driver dbnameseparator="/" defaultport="3050" driver_jar="C:\Program Files\RapidMiner\RapidMiner Studio\lib\jdbc\interclient.jar" drivers="interbase.interclient.Driver" name="Interbase" urlprefix="jdbc:interbase://"/>
</drivers>

Cheers,

Mark




Logged
Pages: [1]
  Print  
 
Jump to: