Pages: [1]
  Print  
Author Topic: NullPointerException when doing logistic regression wrapped under Binary2Poly  (Read 515 times)
shruti_sinha
Newbie
*
Posts: 1


« on: September 22, 2013, 06:02:18 AM »

Hey!
I am working on Rapid Miner to do some analysis for my master's thesis and I am badly stuck when I try to implement logistic regression wrapped under Polynomial to Binomial Classification. My dataset has 3 classes. It has 12 attributes, 532 rows. I have specified the name(of movies) as id, and the class as Label. Except for these two, all other attributes are numeric.
When I try to run the program, I get an error as below:
SEVERE: Here:           Process[1] (Process)
           subprocess 'Main Process'
             +- Retrieve[1] (Retrieve)
             +- Validation[1] (X-Validation)
           subprocess 'Training'
                |  +- Polynominal by Binominal Classification[1] (Polynominal by Binominal Classification)
           subprocess 'Learning Process'
                |        +- Replace Missing Values[3] (Replace Missing Values)
                |        +- Logistic Regression[3] (Logistic Regression)
           subprocess 'Testing'
       ==>         +- Apply Model[1] (Apply Model)
                   +- Performance[0] (Performance (Classification))
Sep 21, 2013 10:53:11 PM SEVERE: java.lang.NullPointerException

My xml file is

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<process version="5.2.008">
  <context>
    <input/>
    <output/>
    <macros/>
  </context>
  <operator activated="true" class="process" compatibility="5.2.008" expanded="true" name="Process">
    <process expanded="true" height="347" width="693">
      <operator activated="true" class="retrieve" compatibility="5.2.008" expanded="true" height="60" name="Retrieve" width="90" x="92" y="187">
        <parameter key="repository_entry" value="//MyRepository/LR/data"/>
      </operator>
      <operator activated="true" class="x_validation" compatibility="5.0.000" expanded="true" height="112" name="Validation" width="90" x="380" y="165">
        <description>A cross-validation evaluating a linear regression model.</description>
        <process expanded="true" height="654" width="466">
          <operator activated="true" class="replace_missing_values" compatibility="5.2.008" expanded="true" height="94" name="Replace Missing Values" width="90" x="45" y="30">
            <list key="columns"/>
          </operator>
          <operator activated="true" class="polynomial_by_binomial_classification" compatibility="5.2.008" expanded="true" height="76" name="Polynominal by Binominal Classification" width="90" x="246" y="75">
            <parameter key="classification_strategies" value="1 against 1"/>
            <process expanded="true" height="347" width="693">
              <operator activated="true" class="logistic_regression" compatibility="5.2.008" expanded="true" height="94" name="Logistic Regression" width="90" x="312" y="98">
                <parameter key="kernel_type" value="polynomial"/>
              </operator>
              <connect from_port="training set" to_op="Logistic Regression" to_port="training set"/>
              <connect from_op="Logistic Regression" from_port="model" to_port="model"/>
              <portSpacing port="source_training set" spacing="0"/>
              <portSpacing port="sink_model" spacing="0"/>
            </process>
          </operator>
          <connect from_port="training" to_op="Replace Missing Values" to_port="example set input"/>
          <connect from_op="Replace Missing Values" from_port="example set output" to_op="Polynominal by Binominal Classification" to_port="training set"/>
          <connect from_op="Polynominal by Binominal Classification" from_port="model" to_port="model"/>
          <portSpacing port="source_training" spacing="0"/>
          <portSpacing port="sink_model" spacing="0"/>
          <portSpacing port="sink_through 1" spacing="0"/>
        </process>
        <process expanded="true" height="654" width="466">
          <operator activated="true" class="apply_model" compatibility="5.0.000" expanded="true" height="76" name="Apply Model" width="90" x="45" y="30">
            <list key="application_parameters"/>
          </operator>
          <operator activated="true" class="performance" compatibility="5.0.000" expanded="true" height="76" name="Performance" width="90" x="179" y="30"/>
          <connect from_port="model" to_op="Apply Model" to_port="model"/>
          <connect from_port="test set" to_op="Apply Model" to_port="unlabelled data"/>
          <connect from_op="Apply Model" from_port="labelled data" to_op="Performance" to_port="labelled data"/>
          <connect from_op="Performance" from_port="performance" to_port="averagable 1"/>
          <portSpacing port="source_model" spacing="0"/>
          <portSpacing port="source_test set" spacing="0"/>
          <portSpacing port="source_through 1" spacing="0"/>
          <portSpacing port="sink_averagable 1" spacing="0"/>
          <portSpacing port="sink_averagable 2" spacing="0"/>
        </process>
      </operator>
      <connect from_op="Retrieve" from_port="output" to_op="Validation" to_port="training"/>
      <connect from_op="Validation" from_port="averagable 1" to_port="result 1"/>
      <portSpacing port="source_input 1" spacing="0"/>
      <portSpacing port="sink_result 1" spacing="0"/>
      <portSpacing port="sink_result 2" spacing="0"/>
    </process>
  </operator>
</process>
Can you tell me where is the problem occuring?

I need urgent help. Please help me. Thanks in advance.
Logged
Marco Boeck
Administrator
Hero Member
*****
Posts: 1015


WWW
« Reply #1 on: September 23, 2013, 08:05:04 AM »

Hi,

can you please post the contents of the rm.log file from the user/.RapidMiner5/ folder?

Regards,
Marco
Logged

Pages: [1]
  Print  
 
Jump to: