Pages: [1]
  Print  
Author Topic: [SOLVED] Using a loop variable within a regular expression?  (Read 404 times)
whitfa
Newbie
*
Posts: 6


« on: July 16, 2013, 06:29:48 PM »

Hi there,

I'd like to pass my loop_value into a regular expression (which is in a Crawl Web parameter, which is inside the Loop Values Operator), however replacing my;

.+period-charts.+today.+

with

.+period-charts.+%{loop_value}.+

isn't working.  Any ideas  Huh

thanks   Smiley
« Last Edit: July 23, 2013, 10:56:26 AM by Marius » Logged
Marius
Administrator
Hero Member
*****
Posts: 1753



WWW
« Reply #1 on: July 22, 2013, 12:36:15 PM »

Can you please post your process XML?

Best regards,
Marius
Logged

Please add [SOLVED] to the topic title when your problem has been solved! (do so by editing the first post in the thread and modifying the title)
Please click here before posting.
whitfa
Newbie
*
Posts: 6


« Reply #2 on: July 23, 2013, 10:52:21 AM »

I beg your pardon Marius. 

It appears that this does in fact work, so long as I don't use the Regex builder / helper within the Crawling Rules of the  CrawlWeb process node.  When I try to include the %{loop_value} within the regex helper, it won't let me <Apply> it because it doesn't like the syntax.  I have to do this without the helper, which is fine because it works.   Grin
Logged
Marius
Administrator
Hero Member
*****
Posts: 1753



WWW
« Reply #3 on: July 23, 2013, 10:56:14 AM »

So we can mark this thread as solved Smiley
Logged

Please add [SOLVED] to the topic title when your problem has been solved! (do so by editing the first post in the thread and modifying the title)
Please click here before posting.
Pages: [1]
  Print  
 
Jump to: