Pages: [1]
  Print  
Author Topic: Erratic behaviour of some learning operators with the Text Plugin  (Read 1366 times)
haltux
Guest
« on: October 31, 2008, 05:31:30 PM »

Hello,

I get strange behaviour with some learning operators using the Text plugin.

For example, using the Text Plugin Sample 01_TextClassificationXVal.xml, when replacing the learning operator by NaiveBayes, all samples go to the same class. Using the Weka version of NaiveBayes, it works fine.

With the same example, when replacing the learning operator by LibSVMLearner, using the default parameter C-SVC and rbf, the results are completely inverted (no true positive, no true negative). With other parameters, there are no problems.

It is not clear whether this problem come from the Text Plugin or Rapidminer itself.

Does anyone have an explanation?

Thanks
Logged
Sebastian Land
Administrator
Hero Member
*****
Posts: 2426


« Reply #1 on: November 03, 2008, 12:50:38 PM »

Hi,
NaiveBayes tries to estimate the normal distribution of the data. If all attribute values are 0, which is the case within this sample process, the resulting normal distribution has mean 0 and variance 0, causing an infinite density at this value and all other values having density 0. Since NaiveBayes assumes independence between all attributes, the probabilities are multiplied. With one empty attribute, the product will become 0, causing the classification to only one class.

The svm seems to invert mappings.

That's for explantion. And now we will start working on it Smiley Thanks for the hint.


Greeting,
  Sebastian
Logged
Pages: [1]
  Print  
 
Jump to: