Pages: [1]
  Print  
Author Topic: Problem with DatabaseExampleSetWriter  (Read 1544 times)
jean-charles
Guest
« on: August 13, 2008, 11:39:26 AM »

Hi Ingo, Hi All,

I have a problem with the operator DatabaseExampleSetWriter. I tried an experiment where I want to "merge" (neither Join, nor Merge, nor anything else) two examplesets outside RM with raw SQL handling.

For that, I installed mySQL and WampServer on a standalone PC. I have verified access rights on a database I have created, called "travail_rapidminer". With or without password, RM does not seem to access this database properly, as I asked it to overwrite output exampleset onto it.

Here is my XML process code :

http://www.mediafire.com/?dummdgmlnm8

and the error box :

http://www.mediafire.com/?tplmnymxxiy

At last, here are my settings on database side :
http://i33.tinypic.com/t9f5tf.jpg

And here is the dialog box that appears before the error box at running :
http://i37.tinypic.com/10y2gwn.jpg

I precise that passwords are coherent, despite the XML experiment does not seem so on this point. Is it a bug, or did I misuse the operator ?

Cheers,
  Jean-Charles.
Logged
Ingo Mierswa
Administrator
Hero Member
*****
Posts: 1226



WWW
« Reply #1 on: August 14, 2008, 05:42:06 PM »

Hi Jean-Charles,

hmm, I must admit that I don't have any clue right now what causes this problem. Did you try if reading from this database works well? The error occurs at a place which actually does not have anything to do which is specific to RM - it directly occurs at the place where the connection is constructed and there is no specific magic done. So I would still assume that there could be an error at the settings. Here is the relevant parts:

Code:
                <operator name="DatabaseExampleSetWriter (3)" class="DatabaseExampleSetWriter">
                    <parameter key="database_url" value="jdbc:mysql://localhost:80/travail_rapidminer"/>
                    <parameter key="overwrite_mode" value="overwrite"/>
                    <parameter key="table_name" value="table_elements"/>
                    <parameter key="username" value="root@localhost"/>
                </operator>

Some questions:

1. did reading from this database works with these settings?
2. port 80 is rather unusual for a database - the default for mySQL is 3306 if I am not mistaken
3. the user name root@localhost is also unusual - did you try "root" alone?

Sorry, I have no other ideas right now.

Cheers,
Ingo
Logged

Did you try our new Marketplace? Upload or download new Extensions, add comments, and organize your operators. Have a look at  http://marketplace.rapid-i.com
jean-charles
Guest
« Reply #2 on: August 26, 2008, 03:15:05 PM »

Hi Ingo, Hi All,

Sorry for the late reply  Tongue
I may try with a different port, 3306 instead of 80, you seem to be right...

Cheers,
   Jean-Charles.
Logged
Pages: [1]
  Print  
 
Jump to: