Pages: [1]
  Print  
Author Topic: Com.rapidminer.tools.xmlexception: Cannot parse document: org.xma.saxParseExcept  (Read 1951 times)
alejandro.tobon
Newbie
*
Posts: 16


« on: July 11, 2009, 04:56:49 PM »

Hi Im getting this error when I put my code in rapaidminer, y Xml format and got to the parameters tab.

Com.rapidminer.tools.xmlexception: Cannot parse document: org.xma.saxParseException: the entity ”iacute” ws referenced, but not declared, Cancel to ignore Changes, or Ok to go on editind.

I using text mining tools because y trying to make a text classifier in Spanish with pages that have HTML Code, where some word have accent and this accent are represented by ”í” on the TokenReplace node,  seems like rapid miner doesn’t like the ampersand.

<operator name="Root" class="Process" expanded="yes">
    <operator name="TextInput" class="TextInput" expanded="yes">
        <list key="texts">
          <parameter key="Sociedad"   value="C:\Clarin Filtrado\Sociedad Text Files"/>
          <parameter key="Deportes"   value="C:\Clarin Filtrado\Deportes Text Files"/>
        </list>
        <parameter key="default_content_language"   value="spanish"/>
        <parameter key="prune_below"   value="3"/>
        <list key="namespaces">
        </list>
        <parameter key="create_text_visualizer"   value="true"/>
        <operator name="ToLowerCaseConverter" class="ToLowerCaseConverter" breakpoints="after">
        </operator>
        <operator name="TildeReplace" class="OperatorChain" expanded="yes">
            <operator name="TokenReplace" class="TokenReplace" breakpoints="after">
                <list key="replace_dictionary">
               <parameter key="&iacute;"   value="i"/>
                </list>
            </operator>
        </operator>
    </operator>     </operator>
« Last Edit: July 11, 2009, 05:05:47 PM by alejandro.tobon » Logged
Simon Fischer
Administrator
Sr. Member
*****
Posts: 448



WWW
« Reply #1 on: July 13, 2009, 08:44:16 AM »

Hi,

this bug originates from a wrong XML export, which does not escape key in parameter lists. This will be fixed in the next release.

So long, you can replace "&iacute;" by "&amp;iacute;" manually. Unfortunately, you have to do that each time you load the process.

Cheers,
Simon
Logged

Simon Fischer, Rapid-I
RapidMiner Development on Twitter: @simon_fis
alejandro.tobon
Newbie
*
Posts: 16


« Reply #2 on: July 13, 2009, 02:46:55 PM »

Thanks a lot, I hope the new release will come soon. Smiley
Logged
Pages: [1]
  Print  
 
Jump to: